Problem kod prebacivanja programa na mBot - Upload to Arduino


#65

Imam jednog robota kojeg ne mogu resetirati na tvornicke postavke.Sve se normalno ucitava,gresku ne javlja ,ali u memoriji i dalje ostane neki stari program. Ima li itko rjesenje?


#66

Bok,možete li možda probati uploadati default program preko Arduino IDEa?Poslati cu vam u privatnoj poruci default program koji dođe sa mBotom :slight_smile:


#67

Mogu probat,naravno!


#68

Da li ste probali napraviti upload firmware-a? Skoro svaka nova verzija mBlock programa dolazi i sa novim firmwareom za robota i često verzije nisu kompatibilne pa ako ste napravili upgrade mBlock programa tada prvo odradite upload firmwarea a tek onda probajte naloadati na default program.


#69

Nisam to probao.Robot je 2 mjeseca radio normalno.


#70

Tek na 2. kolu problem se javio.


#71

Kod svih robota imam istu(stariju) verziju mBlock-a.


#72

Nadogradnju nisam radio.


#73

ako to odradite - neće štetiti :slight_smile: meni klinci dođu na radionice i sa svojim laptopima i tamo nemaju svi istu verziju pa se zna dogoditi da klinci naloadaju svoj FW i da onda nikome drugome ne radi :slight_smile:


#74

Kako rijesiti problem???


#75

,:laughing::laughing::laughing::laughing::laughing::laughing::laughing::innocent::laughing::laughing::laughing::laughing::blush::blush::blush::blush::blush::blush::blush:


#76

Ne pali!!!


#77

Možda su problem baterije(prazne). Probajte ih zamijeniti.


#78

Robot vozi prema programu koji smo pisali.Pritiskom na tipkalo pocima vozit,na reset ga zaustavimo.Taj program je u memoriji robota i nikakav drugi se ne moze ucitat!


#79

Zbog praznih baterija zna se dogoditi da ne usnimi novi program. Provjerite kod USB ulaza lem spoj… jeli ima vidjlivih oštećenja i unutrašnjost ulaza kod USB (usporedite s ispravnom pločicom)… moraju se vidjeti pinovi https://www.usb3.com/usb2-Bpinout-600.jpg


#80

Imam konstantan problem sa kompajlanjem programa.

Error msg:

C:\Program Files\mBlock\Arduino\hardware\tools\avr\bin\avr-ar: unable to rename ‘C:\Users\PROF\AppData\Local\Temp\build6818350837893205242.tmp/core.a’; reason: Permission denied

i

C:\Program Files\mBlock\Arduino\hardware\tools\avr\bin\avr-ar: unable to rename ‘C:\Users\PROF\AppData\Local\Temp\build6872597679155396376.tmp/core.a’; reason: File exists

Greška pri kompajliranju.

Kada potražim “core.a” na navedenoj lokaciji uopće ga ne nalazim.
Nakon upgrejda firmwarea i uploada defaultnog programa nekada uspije prebaciti program, ali već idući upload faila. Win 10, mBlock ver.3.4.6.

Ima li netko kakvu sugestiju?


#81

Zvuči kao da se Windows i mBlock tuku.

Ovo bi bio ružan ali jednostavan hak: probajte pokrenuti kao administrator (možda upali).

Malo nježnija varijanta ali i dalje ružan hak: pokušajte si dati dopuštenja za čitanje i pisanje u instalaciju mBlocka (C:\Program Files\mBlock, uključujući i sve podmape i datoteke).

Ili vidjeti ako je izašla novija verzija mBlocka koja uz malo sreće nema taj problem.


#82

Moguće je i još nekoliko scenarija ako ne upali ovo sa administratorskim pravima:

Ako imate antivirus - probajte ga privremeno isključiti i vidite da li je on tu kriv. Isto tako ako imate neki od security programa koji vam provjeravaju datoteke u pozadini - probajte raditi compile dok su oni isključeni

Druga mogućnost je da imate neki malware/virus koji vam u pozadini petlja po datotekama pa ako nemate antivirus tada probajte provjeriti mašinu sa nekim antivirusnim alatom.


#83

Pozdrav! Imam problem pri prebacivanju programa na mbot. Evo kako to izgleda:


ako moze pomoc… Unapred hvala!!! :slight_smile: